Skip to main content
All CollectionsCompatibility
Minimum Requirements
Minimum Requirements

Unfortunately, your original iPod won't be able to use GameGlass. Find out what WILL here!

Craig Sartor avatar
Written by Craig Sartor
Updated over a week ago

Minimum Device Requirements

GameGlass runs on a broad range of devices and browsers, check the table below to confirm yours meets the minimum criteria.

Device

Operating System

Android Smartphone or Tablet

Android 7 or above

Apple iPhone/iPad

iOS 13 or above

Amazon Fire/FireHD

FireOS 6 or above

Microsoft Surface Pro *

Windows 10, 11

Host and Secondary Client PCs

Windows 8.1, 10, 11

* Windows RT and Surface X based devices on the ARM processor are not compatible.


Older Device Compatibility

GameGlass may still run on devices prior to the versions listed above however your experience may not be ideal. We encourage you to test out any older device you have laying around the house to determine for yourself if or how it functions with GameGlass. When buying a new device however we strongly recommend you choose one that meets our official support requirements.


Supported Browsers

If you are planning to use GameGlass through your browser (app.gameglass.gg)

Browser

Operating System(s)

Minimum Version

Google Chrome

Any

100.x or above

Mozilla Firefox

Any

100.x or above

Apple Safari

MacOS, iOS

13.x or above

Amazon Silk

Fire OS

Latest only

Microsoft Edge

Any

Latest only

NOTE: If your Device's OS doesn't meet the minimum criteria in the Supported Devices chart then the browser app may not work even if you are running the latest Supported Browser.

Did this answer your question?